Instalar impressora Elgin i9 no Linux

Neste vídeo vou mostrar como instalar a impressora Elgin (cupom não fiscal) no Linux Mint 20. Funciona nos derivados como Ubuntu, Pop, etc

😉 Gostou do vídeo, que tal me pagar um cafezinho? ☕ https://picpay.me/dane.infocotidiano

Instalando MySQL e Workbench no Debian 10

Neste vídeo mostro como instalar o MySQL 8 e o Workbench no Debian 10 “Buster”.

Diferente do Ubuntu e do Mint (derivados do Debian), abaixo a lista de Comandos:

sudo apt update
sudo apt upgrade
wget http://repo.mysql.com/mysql-apt-confi…
sudo dpkg -i mysql-apt-config_0.8.13-1_all.deb
Lembre-se que a senha deve ser segura, letras e números, exemplo: Teste@3223
sudo apt update
sudo apt install mysql-server
sudo apt-get build-dep mysql-server
wget https://downloads.mysql.com/archives/…
sudo dpkg -i mysql-workbench-community_8.0.16-1ubuntu18.04_amd64.deb
sudo apt install -f
sudo dpkg -i mysql-workbench-community_8.0.16-1ubuntu18.04_amd64.deb

Veja o Vídeo:

#installmysqldebian #instalarmysqldebian #mysqlinstallierendebian #debianmysqlinstallieren #mysqlaufdebianinstallieren #mysqlnodebian #mysqldebianrepository #mysqldebian #mysqldebianapt-get #mysqldebianapt #mysqlfordebian #mysqlworkbenchdebianbuster
#mysqldebianconfigure #mysqldebiandownload #instalaciondemysqldebian #mysqlendebian

Instalando MySQL Server, WorkBench no Ubuntu, Mint , Debian – 2018

Salve amigos, neste vídeo mostro como instalar o MySQL Server no novo Ubuntu 18.04, Mint 19 e derivados do novo Debian.

Fonte https://linuxconfig.org/install-mysql-on-ubuntu-18-04-bionic-beaver-linux

Comandos:
sudo apt install mysql-server
sudo mysql_secure_installation
Edite e mude bind-address para 0.0.0.0
sudo nano /etc/mysql/mysql.conf.d/mysqld.cnf
sudo service mysql restart
sudo mysql -u root
ALTER USER ‘root’@’localhost’ IDENTIFIED WITH mysql_native_password BY ‘SuaSenha’;


Instalando Firebird 2.5 e Famerobin no Elementary OS

Neste vídeo vou mostrar como instalar o firebird 2.5 no Linux Elementary OS Loki.

Super fácil !!!!!!

Comandos:

sudo su
apt-get install firebird2.5-superclassic
dpkg-reconfigure firebird2.5-superclassic

(senha padrão do SYSDBA é masterkey)

Obrigado !

Assista o vídeo:

Compartilhar pastas e arquivos no Elementary OS

Neste vídeo vou mostrar como compartilhar pastas e arquivos através do terminal do Linux

Vídeo útil para quem não tem acesso ao modulo gráfico para instalação e configuração do samba.

Vou pastar os comandos do terminal aqui:

p { margin-bottom: 0.25cm; line-height: 120%; }

#Instalando Samba:
sudo apt-get install samba
samba-common
#Adicionando meu usuario ao
samba:
sudo smbpasswd -a danegd
#Fazendo Backup do smb.conf:
sudo cp /etc/samba/smb.conf
/etc/samba/smb.conf.old
#Editando smb.conf:
gedit /etc/samba/smb.conf

[Downloads]
comment = Downloads
path =
/home/danegd/Downloads/
guest ok = no
browseable = yes
create mask = 0600
directory mask = 0700
Iniciando / Parando servico
service smbd start/stop

Assista o vídeo:

Resolvendo problemas com wireless Atheros QCA6174 Ubuntu

Comprei um notebook Dell Inspiron Special Edition 5557 (15″/ i7 6a grn/ 1Tb HD/ 8Gb RAM/ 4Gb VGA/ Linux Ubuntu) em 05/2016 veio com o Ubuntu pré-instalado pela Dell, mas formatei com o Ubuntu 16.04 Lts com partições separadas como prefiro.

Começou a minha dor de cabeça… a placa de rede não é reconhecida pelo Ubuntu 16.04. Instalei Debian 8.4, Fedora 23, Mint 17e a rede wifi não funcionava.
 
A Dell não disponibiliza o driver para Ubuntu, o suporte via chat a pessoa quando falei que era Linux ele já foi ficando apavorado olhe o que ele me disse:

05/25/2016 12:44:47PM Agent (SYKc_Chat ): “Senhor , no caso a DELL não garante funcionalidade da maquina com outros sistemas não embarcados na maquina .”

Meu Dell veio com Ubuntu de Fábrica !!!!!

Uma observação: no site da Dell informa que minha placa de rede é uma Dell Wireless 1820 Wi-Fi+ Bluetooth

Depois de muitas pesquisas, descobri como fazer funcionar. Só tive tempo de postar hoje, mas é valido para quem sofreu como eu kkk !

Para saber se a sua placa é uma Atheros QCA6174, execute o comando:

lspci e procure pelo seu dispositivo, ou  teste o comando lspci | grep Wireless
ele vai retornar algo parecido:

02:00.0 Network controller: Qualcomm Atheros QCA6174 802.11ac Wireless Network Adapter (rev 32)


* * * Atenção ! Lembre-se de fazer backup
Não me responsabilizo por qualquer problema que venha acontecer caso o procedimento não der certo para você ! * * * * 

1. É obrigatório que a kernel do seu Ubuntu seja: 4.5.0 ou superior.
Para verificar qual versão da sua kernel use o comando: uname -r
(um usuário reportou q funcionou na kernel 4.4.0-31-generic mas não testei)

Como a minha kernel era inferior eu tive que atualizar para 4.5.0, usei os comandos que localizei neste site http://ubuntuhandbook.org:

Meu Ubuntu é 64 bits então executei os seguintes comandos:

cd /tmp/

wget http://kernel.ubuntu.com/~kernel-ppa/mainline/v4.5-wily/linux-headers-4.5.0-040500_4.5.0-040500.201603140130_all.deb

wget http://kernel.ubuntu.com/~kernel-ppa/mainline/v4.5-wily/linux-headers-4.5.0-040500-generic_4.5.0-040500.201603140130_amd64.deb

wget http://kernel.ubuntu.com/~kernel-ppa/mainline/v4.5-wily/linux-image-4.5.0-040500-generic_4.5.0-040500.201603140130_amd64.deb

sudo dpkg -i *.deb

reinicie o Ubuntu

 

Depois disso, segui os passos deste forum: https://bugs.launchpad.net/ubuntu/ post #22:


sudo mkdir -p /lib/firmware/ath10k/QCA6174/hw3.0/

sudo rm /lib/firmware/ath10k/QCA6174/hw3.0/* 2> /dev/null

sudo wget -O /lib/firmware/ath10k/QCA6174/hw3.0/board.bin https://github.com/FireWalkerX/ath10k-firmware/blob/7e56cbb94182a2fdab110cf5bfeded8fd1d44d30/QCA6174/hw3.0/board-2.bin?raw=true

sudo wget -O /lib/firmware/ath10k/QCA6174/hw3.0/firmware-4.bin https://github.com/FireWalkerX/ath10k-firmware/blob/7e56cbb94182a2fdab110cf5bfeded8fd1d44d30/QCA6174/hw3.0/firmware-4.bin_WLAN.RM.2.0-00180-QCARMSWPZ-1?raw=true

sudo chmod +x /lib/firmware/ath10k/QCA6174/hw3.0/*

Reinicie o Ubuntu e tudo vai funcionar perfeitamente !

* Atenção: Este procedimento funciona no Manjaro Linux 16.06.1 Daniella 64.
Só a atualização do kernel fiz pelo “Manjaro Settings Manager”.

Instalando PostGreSQL e pgAdmin III no Ubuntu

Um pouquinho mais sobre PostGreSQL:
Hoje, o PostgreSQL é um dos SGBDs (Sistema Gerenciador de Bancos de
Dados) de código aberto mais avançados, contando com recursos como:

  • Consultas complexas
  • Chaves estrangeiras
  • Integridade transacional
  • Controle de concorrência multi-versão
  • Suporte ao modelo híbrido objeto-relacional
  • Ele tem facilidade de Acesso
  • Gatilhos
  • Visões
  • Linguagem Procedural em várias linguagens (PL/pgSQL, PL/Python, PL/Java, PL/Perl) para Procedimentos armazenados
  • Indexação por texto
  • Estrutura para guardar dados Georeferenciados PostGIS

     (fonte: https://pt.wikipedia.org/wiki/PostgreSQL)

Fiz um vídeo para mostrar como instalar o PostGreSQL e o pgAdmin III que é o aplicativo para manutenção e gerenciamento do banco de dados: